Version History

Revision as of 19:55, 7 June 2020 by CaptainBlack (talk | contribs)

Please check the list of Known Issues and to-do list

07/05/2020 (0.6.2)

General

  • Moved config files to .config/octarine directory
  • Added a preferences dialog.
  • Reworked the UI styling to fix some glitches with the dockable windows.
  • Fixed "Export" item on map menu was permanently disabled.

Sprite Editor

  • Fixed an issue when importing images as a new sprite sheet that resulted in no tiles created.

Map Editor

  • It is now possible to copy regions between maps, providing they both use the same tile set.
  • Fixed a problem with checking for duplicate tiles when importing images, that would ignore a tiles rotated status.
  • Fixed tooltip showing incorrect info in the tile picker tool.
  • Fixed a crash when closing a project and moving the mouse in the tile picker
  • Tile picker didn't change tile sets when activating a different map
  • Fixed map editor copy as image didn't work
  • Fixed a crash when pasting tiles and some of the tiles fall outside of the map.

31/05/2020 (0.6.1)

General

  • Added missing view->Map Objects menu
  • Reset tile list when closing project
  • Added online version check
  • Fixed the broken links in the About dialog
  • Fixed slowdown/freeze when changing a palette entry and a map document is open
  • Started to add in a proper toolbar, beginning with the File menu actions.

Map Editor

  • Added initial import for NextTiles format files. Based on a little guesswork, so needs testing. Requires four files with the extensions: .nxp, .nxt, .nxm and .nxb
  • Added abaility to import images as new tilemap and tileset. The algorthm will do it's best to slice the image into tiles, deduplicate each one based on flip, mirror and rotation and finally optimise the colours into a new palette.
  • Fixed map editor picker tool wasn't wired up, so didn't actually change the selected tile in the other windows.
  • Optimised the map rendering code for a big speedup, especially with large map areas.
  • Changed the styling of selected areas, speeds up rendering and is more natural.
  • Fixed the behaviour of select/copy/paste.
  • Wired up select all.
  • Added selection context menu with cut, copy, paste, fill and erase options, more will be added

Tile Editor

  • Rewrote to the tile selection grid to be more consistent with the sprite selection grid.
  • Added context menu to tile selection grid, zoom in, zoom out, clear tile, copy image and paste image
  • Added Next and Previous tiles to the tile menu
    • Windows/Linux shortcut Ctrl-] Ctrl-[
    • Mac Shortcut ⌘-], ⌘-[
  • Added Tile List Magnification menu
  • Added tooltips to the tile picker tool

Sprite Editor

  • Importing .spr file now properly sets bank name to filename instead of just "imported"

23/05/2020 (0.6)

General

  • Renamed a few menu items
  • Tile selection window zoom level is now remembered when opening the app.
  • Changed some of the control styling to make it obvious when they are disabled.
  • Fixed a bug where deleting a sprite bank caused a crash when subsequently using the sprite importer

Sprite Editor

  • Reworked importing of SPR files to allow appending to the current sprite bank
  • Reworked importing of image files to allow appending to the current sprite bank or using a different palette
  • Changed the import binary data dialog with better options
  • Changed the import image dialog with better options
  • Fixed resizing sprite list when a sprite is added or deleted
  • Implemented "Clear" sprite context menu item
  • Implemented Drag and Drop in the sprite list
    • Drag and drop a sprite to move it to a new slot
    • Hold shift to copy a sprite to a new slot
  • No longer displays the context menu when clicking on the + icon in the sprite list
  • Removed the requirement of an existing palette when creating a new sprite bank
  • Fixed a crash in the sprite animation editor when clicking on an animation frame
  • Added "Copy Image" and "Paste Image" context menu items for the sprite list. You can now copy individual sprites to and from the clipboard.
  • Added mouse hover highlight for sprite list

MacOS

I've registered as an Apple developer, which means I can now code sign the MacOS version. This will stop future versions causing Gatekeeper from nagging users when the app is first run.

15/05/2020 (0.5.5)

General

  • Fixed an issue that caused colour values to be off by 1 in the palette editor
  • Fixed closing a tab would often close more than one document.
  • Cleaned up some of the UI styling niggles.
  • Fixed a crash when deleting a sprite bank

Map Editor

  • Moved the tile selector and Object listsinto a moveable/resizeable/dockable windows

Sprite Editor

  • New sprite banks start out with a single sprite
  • Sprite banks are no longer limited to 64 sprites
  • Added a + icon, to add a new sprite.
  • Added context menu to sprite list

05/05/2020 (0.5.4)

General

  • Fixed a crash when renaming a block list
  • Fixed copying a selection on the canvas copied the wrong coordinates
  • Fixed an issue pasting to a canvas editor, the selected areas pixels are now rendered in the canvas current palette.
  • Fixed changing tabs didn't always updated the active tile set in the tile editor window

Tile Editor

  • Added export options dialog and the ability to export tiles as 8-bit pixel data for use on Layer 2

Image Editor

  • Fixed an issue where the grid overlay would be drawn past the bottom of the draw area

Sprite Editor

  • Fixed: sprite list did not properly erase the background

06/04/2020 (0.5.3)

General

  • Fixed view menu items were incorrectly set to never checked, so tool windows would not reappear
  • Fixed crash when saving a project
  • View->Window menu items now properly reflect each windows visibility
  • Added "Reset Layout" to the view menu
  • Changed the styling of combo boxes to make it more obvious when they are disabled.
  • Cleaned up the items in the project tree view
  • Added "Delete" context menu item to the project window, you can now delete items from the project
  • Sprite documents are now reopened when loading a project

Sprite Editor

  • Fixed a crash removing items from the list in the sprite editor
  • Fixed a crash when importing images with > 64 sprites
  • Changing frames in the sprite editor will now correctly update the flip/mirror/rotate button states
  • Made the selected cell in the sprite editor stand out more
  • Added a context menu to the sprite frame editor with options to change the cells flip, mirror and rotate state
  • Added "Export" menu allowing the user to export sprite data as raw 16k sprite banks
  • Fixed selecting pixels in the edit was off 1 in some instances
  • Fixed editing a palette didn't correctly update the sprite colours
  • Added an indicator to the colour picker, highlighting the colour under the mouse pointer.

Map Editor

  • Fixed an issue that caused the create map dialog to not appear
  • Added a "Palette" icon to the toolbar: This will reset the palette offsets of each cell on the map to match the default offset for the tile in that cell.
  • The Block/Object list should now be refreshed when adding new items in the object editor.

Image Editor

  • Added ability to create new images and added an Images menu
    • Images are now correctly stored and retrieved from the project file
  • Fixed crash when opening scratch image editor

Project Window

  • Reorganised how items appear in the tree, Map Objects now appear beneath the tile set they belong to

06/04/2020 (0.52)

Sprite Editor

  • Added the ability to import .spr files and 256 colour bmp and png images
    • Added deduplicator, checks to see if any imported sprites are duplicates (flipped, mirrored or rotated)
  • Fixed sprite editor crash when switching sprites while animation was playing
  • Fixed flip/mirror were mixed up on the sprite editor toolbar

Map Editor

  • Fixed rendering of the selected block in the top left of the map when the mouse leaves the editor

General

  • Rearranged the menus
    • Added Import/Export to palette menu
  • Fixed about dialog didn't display
  • Fixed a crash loading empty projects
  • Added website and social media links to the About dialog
  • Added a new image import module, this will help me optimise images when importing them into different areas.

25/03/2020 (0.5.1)

Sprite Editor

  • Fixed a crash when clicking on rotate/flip/mirror
  • Added menu item to enable swapping of palettes

Map Editor

  • Fixed a minor tile rendering issue when displaying the selected tile at the mouse cursor

Tile Editor

  • Added menu item to enable swapping of palettes
  • Added ability to import 768 byte character sets

General

  • Fixed the colour picker not showing all colours in vertical mode
  • Fixed hilighting the drop position on the tile picker grid when leaving the mouse leaves the control

23/03/2020 (0.5.0)

Map Object Editor

  • Fixed aspect ratio for thumbnails in the list view
  • Any open editors will be restored when the project is loaded
  • Added a "Palette" toolbar button - this will reset all tiles in the current animation to thier default palette offset values.
  • Fixed the "Delete" functionality, animations are now correctly deleted, not just removed from the list.

Map Editor

  • Added the ability to place Map/Animation objects on a map
  • Fixed a problem with placing non square objects on the map
  • Added a snap to value which allows tiles to be placed at 2x2,3x3 etc boundaries

Sprite Editor

  • Added initial version of the sprite editor tool (Supports only 256 colour sprites for the time being)

General

  • Fixed the RGB editor popover, it will now correctly display outside the main window and over the top of all other controls
  • Fixed a bug that reset all the palette offsets when loading a map from the project file.

10/03/2020 (0.4.0)

Map Object Editor Preview

  • First preview release of the new map object editor.
    • Group tiles into larger blocks
    • Add multiple animation frames
    • Animation pplayback
  • Missing features
    • The map editor does not yet have the functionality to add these blocks to a map

Image Editor

  • Fixed an issue with the RGB editor popover appearing multiple tiles
  • After picking a colour, the mode is changed to draw

Map Editor

  • Fixed cut/paste was not working correctly

Tile Editor

  • Added attributes editor (see Tile Editor docs)
  • After picking a colour, the mode is changed to draw
  • Added "1" and "2" to the colour picker to make it easier to see which entries are selected

General

  • Fixed "Save As" didn't work
  • Refactored a lot of the Dialog logic for creating new project items.

Palette Editor

  • Increased the size of the RGB slider handles

23/02/2020 (0.3.6)

General

  • Moved the change log from the about box to the wiki.
  • Now remembers which map editors were open when you last saved the project, so opening a project should also open the relevant tabs

Map Editor

  • Fixed the draw area calculations of the map editor window
  • Tile list and map will now update tiles when a palette entry is updated
  • Added grid lines (As per Andy's request)
  • Undo now works after pasting tiles
  • Improved the behaviour of copy/paste modes
  • Added initial tile map transparency handling code

Image Editor

  • Added Line and rectangle drawing modes.
  • Added a new colour picker, with popover RGB editor (double click an entry to activate)
  • Re-Added fill tool
  • Implemented export image
  • Implemented Undo!
  • Holding the left mouse for > 0.5 seconds on a tool button will popup a context menu (if one is defined)
    • More will be added, e.g. to set the wether a rectangle/circle is filled or hollow etc.

Tile Editor

  • Added fill tool
  • Fixed an issue with pixels not drawing when creating a new tile set
  • Implemented Undo. This uses the same control as the image editor, so not everything is undo-able yet.

Project View

  • Added a context menu
  • Added a little splash of colour

03/02/2020 (0.3.5)

Tile Editor

  • Fixed an issue that caused the tile editor paint canvas to not work correctly after creating a new project

Map Editor

  • Fixed a crash when clicking on an invalid tile in the tile list
  • Fixed a bug that caused the tile list to not update when a tile was edited
  • Fixed middle click to select a tile caused the tile under the mouse to be replaced
  • When picking a tile from the map, the tile list will now scroll to the selected tile

Scratch/Image Editor

  • Fixed a few niggles with the tool buttons and a couple of random crashes

General

  • Fixed the create tile set dialog incorrectly disable some controls
  • Fixed loading older versions of the project file caused a crash
  • Refactored the create new project and open project UI code
  • When changing tabs, the relevant tool windows will now be activated

02/02/2020 (0.3.4)

General

  • Added diagnostic logging to help track down crashes
  • The scratch image is now stored and retrieved from the project file

Image Editor

  • Fixed an issue that caused a crash when pasting an image
  • Improved positioning and visual style when pasting an image in the canvas widget
  • Map Editor

    • Fixed an issue calculating the scroll area when one of width or height was smaller than the display area
    • Implemented middle mouse click to pick the tile under the cursor
    • Added Export Map Data dialog, data can now be exported in raw binary

    Tile Editor

    • Fixed a crash when moving the tile by 1 pixel
    • Added rotate/flip/mirror functions back to tile editor
    • Added grid lines

    24/01/2020 (0.3.3)

    Palette Editor

    • Fixed: RGB Sliders now move by 1 when click either side of the handle

    Map Editor

    • New: Use [ and ] to switch to previous and next tile in the tile list
    • New: Shift Click now switches to select mode on the map editor grid
    • New: Shift+Drag to copy a tile in the tile list
    • New: Resize map dialog, currently only allows expanding the map dimensions

    Tile Editor

    • Fixed: Crash when setting a different tile set after loading a different project

    General

    • Fixed a couple of memory leaks and crashes, hopefully should be a little more stable

    22/01/2020 (0.3.2)

    Map Editor

    • Added: Ability to undo actions - undo stack is limited only to available memory
    • New: Rewrote the tile picker to be more dynamic and added a splitter so you can resize the map/tile picker
    • New: Double clicking on a tile now selects it in the tile editor
    • Fixed: Pasting over the edge of the map had unpredictable results
    • Added: Drag and drop tile reorder in the tile selector

    Tile Editor

    • Fixed: Issue with colour selector not selecting correct index
    • Fixed: Expanding the palette editor causes the properties editor to expand
    • Fixed: Pasting an image missed the top and rightmost pixels
    • Fixed: Couldn't set a palette entry to 0:0:0

    General

    • Fixed: Tracked down a couple of memory leaks (the joys of C++)

    19/01/2020 (0.3.1)

    Map Editor

    • Fixed: Zoom level on tile selector
    • Fixed: Mouse wheel handing, hold shift to scroll left/right, ctrl (cmd on mac) to zoom in and out
    • Added: Ability to resize a map using the +/- buttons on the scrollbars
    • New: Opening a map will also activate the correct tile set in the tile editor

    18/01/2020 (0.3)

    Image Editor

    • Started work on a generic image editor component
    • Added better clipboard handling, you can now copy paste between the image/tile editor

    Tile Editor

    • Rewrote the drawing code
    • Rewrote the flood fill, fixes a crash on large images
    • Added a better keyboard shortcut handler

    07/01/2020

    General

    • Added: About dialog and changelog

    Tile Editor

    • Added: Flood fill
    • Added: Working colour picker
    • Added: Double clicking on a colour will activate the correct entry in the palette editor
    • Fixed: Palette editor controls were not updated when first expanded

    06/01/2020

    Tile Editor

    • Added: Clear selection

    General

    • Changed: better scrollbar arrow icons